博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
Pascal's Travels
阅读量:4679 次
发布时间:2019-06-09

本文共 2074 字,大约阅读时间需要 6 分钟。

Problem Description
An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.
Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.
Figure 1
Figure 2
 
Input
The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
 
Output
The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.
 
Sample Input
4 2331 1213 1231 3110 4 3332 1213 1232 2120 5 11101 01111 11111 11101 11101 -1
 
Sample Output
3 0 7
题意:给定一个二维图,给出图中每个点到其他点的最大步数,求从最左上出发到最右下的的步数
题解:定义一个二维数组p[i][j],p[0][0]=1;设当前点能走的最大步数为k
p[i+k][j]+=p[i][j];p[i][j+k]+=p[i][j];
AC代码:
#include<stdio.h>
#include<string.h>
__int64 p[50][50];
char ms[50][50];
int main()
{
    __int64 i,n,j,k;
 while(scanf("%I64d",&n)&&n!=-1)
 {
  memset(p,0,sizeof(p));
  p[0][0]=1;
  for(i=0;i<n;i++)
  {
   scanf("%s",ms[i]);
  }
  for(i=0;i<n;i++)
  {
   for(j=0;j<n;j++)
   {
    k=ms[i][j]-'0';
                 if(k==0) continue;
     if(j+k<n) p[i][j+k]+=p[i][j];
     if(i+k<n) p[i+k][j]+=p[i][j];
   }
  }
  printf("%I64d\n",p[n-1][n-1]);
 }
 return 0;
}
 
 

转载于:https://www.cnblogs.com/ffhuguang/p/3203968.html

你可能感兴趣的文章
评论博客
查看>>
用户代理字符串识别工具源码与slf4j日志使用
查看>>
提示框第三方库之MBProgressHUD
查看>>
C语言 10-字符和字符串常用处理函数
查看>>
C++ 表达式语句 海伦的故事
查看>>
32位汇编学习笔记(1)
查看>>
day_01
查看>>
2013年12月日本語能力試験N3聴解部分
查看>>
uva 1349(拆点+最小费用流)
查看>>
关于SessionFactory的不同实现类分别通过getCurrentSession()方法 和 openSession() 方法获取的Session对象在保存对象时的一些区别...
查看>>
Web开发细节搜集
查看>>
织梦kindeditor图片上传增加图片说明alt属性和title属性
查看>>
HTML fieldset标签
查看>>
Qt 之 饼图
查看>>
算法总结系列之二: 快速排序(QuickSort)
查看>>
会放弃的人生才会更洒脱
查看>>
正则匹配、替换
查看>>
太阳能路灯软件设计
查看>>
二 面向对象
查看>>
Swift,下标简化方法的调用
查看>>